Unable to install plugins that depend on nokogiri in Vagrant 1.6+

If you encounter this issue while performing vagrant plugin update or vagrant plugin install that require nokogiri

Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

An error occurred while installing nokogiri (1.6.2.1), and Bundler cannot continue.
Make sure that `gem install nokogiri -v ‘1.6.2.1’` succeeds before bundling.

This solution works for me (OSX 10.9.3):

add s.add_dependency(%q, [“< 1.6.2”]) to /Applications/Vagrant/embedded/gems/specifications/vagrant-1.6.2.gemspec

For reference : https://github.com/mitchellh/vagrant/issues/3769